rules-template 442 B

1234567891011121314151617181920
  1. #!/usr/bin/make -f
  2. export DH_VERBOSE = 1
  3. export DEB_BUILD_OPTIONS=parallel=4
  4. override_dh_auto_configure:
  5. dh_auto_configure -- -DBUILD_SHARED_LIBS=ON -DCMAKE_BUILD_TYPE=RelWithDebInfo -DUA_NAMESPACE_ZERO=FULL -DUA_ENABLE_AMALGAMATION=OFF -DUA_PACK_DEBIAN=ON
  6. override_dh_auto_test:
  7. dh_auto_test -- ARGS+=--output-on-failure
  8. override_dh_strip:
  9. dh_strip --dbg-package=libopen62541-<soname>-dbg
  10. %:
  11. dh $@ --buildsystem=cmake --parallel