rules-template 451 B

123456789101112131415161718
  1. #!/usr/bin/make -f
  2. export DH_VERBOSE = 1
  3. export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
  4. override_dh_auto_configure:
  5. dh_auto_configure -- -DBUILD_SHARED_LIBS=ON -DCMAKE_BUILD_TYPE=RelWithDebInfo -DUA_NAMESPACE_ZERO=FULL -DUA_ENABLE_AMALGAMATION=OFF -DUA_PACK_DEBIAN=ON
  6. override_dh_auto_test:
  7. dh_auto_test -- ARGS+=--output-on-failure
  8. override_dh_auto_build:
  9. dh_auto_build -- -j`nproc --ignore=2`
  10. %:
  11. dh $@ --buildsystem=cmake --parallel